Показано с 1 по 2 из 2

Тема: multiwan и openwrt

  1. #1
    Проходил Мимо
    Регистрация
    11.06.2012
    Адрес
    ukraine
    Сообщений
    1
    Вес репутации
    0

    По умолчанию multiwan и openwrt

    пытаюсь настроить роутер на работе для работы на 2х провайдеров сразу
    ориентир держу на вот эту статью
    с некоторыми поправками
    Код:
    config switch_vlan 
            option device 'eth0'  
            option vlan '1'       
            option ports '0 1 2 3 4'
    было выяснено опытным путем что порты 1-4 принадлежат
    порт - цифра
    1-2
    2-3
    3-4
    5-1

    соответственно я полагаю что 0 это внутренний интерфейс.
    а также настройка операторов отличается тем что у обеих dhcp будет
    дык воть
    ------------------------------
    вот мой /etc/config/network
    Код:
    config interface 'loopback'           
            option ifname 'lo'            
            option proto 'static'         
            option ipaddr '127.0.0.1'     
            option netmask '255.0.0.0'    
                                          
    config interface 'lan'                
            option ifname 'eth0'          
            option type 'bridge'          
            option proto 'static'         
            option ipaddr '192.168.1.1'   
            option netmask '255.255.255.0'
                                    
    config interface 'wan'          
            option ifname 'eth1'    
            option proto 'dhcp'   
    
    
    config switch                         
            option name 'eth0'            
            option reset '1'              
            option enable_vlan '1'        
                                          
    #config switch_vlan                   
    #       option device 'eth0'          
    #       option vlan '1'               
    #       option ports '0 1 2 3 4'      
                                          
    config switch_vlan                    
            option device 'eth0'          
            option vlan '1'         
            option ports '0 1 3 4'  
                                    
    config switch_vlan1             
            option device 'eth0'    
            option vlan '2'         
            option ports '0 2' 
    ######################################
    config interface 'wwan'               
            option ifname 'eth0.2'        
            option proto 'dhcp'
    по логике вещей если я воткну кабель во второй порт у меня должен за работать инет (но не работает)
    ifconfig говорит на этот интерфейс следующее
    Код:
    eth0.2    Link encap:Ethernet  HWaddr 64:70:02:F0:1B:DF  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:160 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:0 (0.0 B)  TX bytes:62880 (61.4 KiB)
    параметры файрвола в LuCI на странице Network ? Interfaces ? WWAN ? Firewall settings указал зону wan.
    как было в инструкции

    ЧТО я заделал не так?
    спасибо

  2. Производство антенн и усилителей Разместить рекламу на LAN23.RU банер продать ссылку
  • #2
    Проходил Мимо
    Регистрация
    31.03.2013
    Адрес
    Россия Орёл
    Сообщений
    1
    Вес репутации
    0

    По умолчанию

    Может уже не актуально, но сам только столкнулся с проблемой распределения трафика по нескольким провайдерам. Использую TL-MR3220.
    Порт WAN(синий) переделал в LAN, а 4 LAN-порта стали WAN-ами. Использую только два порта для подключения провайдеров, поэтому остальные отключил.
    Wireles тоже пока не использую, его можно подключить куда угодно.
    Мой /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config interface 'lan'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option _orig_ifname 'eth0 radio0.network1'
    option _orig_bridge 'true'
    option ifname 'eth1'
    option ipaddr '192.168.5.3'

    config interface 'wan'
    option proto 'dhcp'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'
    option ifname 'eth0.2'

    config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'eth0'
    option vlan '1'
    option vid '1'
    option ports '0t 3'

    config switch_vlan
    option device 'eth0'
    option vlan '2'
    option vid '2'
    option ports '0t 4'

    config interface 'wan2'
    option proto 'dhcp'
    option ifname 'eth0.1'



  • Похожие темы

    1. USB к TPLINK TL-WR741ND под OpenWrt
      от Bebebe в разделе Модификация Wi-Fi оборудования
      Ответов: 77
      Последнее сообщение: 16.09.2018, 08:22
    2. Шейпер в OpenWrt
      от харёк в разделе Новичкам
      Ответов: 0
      Последнее сообщение: 06.01.2012, 18:44
    3. Linksys WRT160nl с OpenWrt
      от z-i-b1974 в разделе Модификация Wi-Fi оборудования
      Ответов: 18
      Последнее сообщение: 13.11.2010, 00:24
    4. openwrt добавление канала
      от xumuk в разделе Модификация Wi-Fi оборудования
      Ответов: 0
      Последнее сообщение: 08.09.2010, 09:16
    5. Прошивка DWL700AP в OpenWRT
      от clgs в разделе Модификация Wi-Fi оборудования
      Ответов: 7
      Последнее сообщение: 17.05.2010, 16:47

    Ваши права

    • Вы не можете создавать новые темы
    • Вы не можете отвечать в темах
    • Вы не можете прикреплять вложения
    • Вы не можете редактировать свои сообщения
    •